Resolved
Everything back to normal. Sorry for the inconvenience.
Identified
A pooler issue in our main database is creating contention and refusing some connections. We identified the issue and working on fixing it.
Investigating
An unscheduled maintenance had to be performed this morning and is causing retries on the API