This incident is now resolved. Pre-recorded transcription in Europe is operating normally.
Average end-to-end latency for new jobs in the EU pipeline is approximately 25 seconds, with queue wait under 10 seconds and transcription completing in about 20 seconds on average. These values are in line with our usual operating range.
Jobs submitted during the earlier slowdown have been processed. Service is fully restored.
We apologize for the disruption. If you continue to experience issues, please contact us at support@gladia.io.
Resolved
This incident is now resolved. Pre-recorded transcription in Europe is operating normally.
Average end-to-end latency for new jobs in the EU pipeline is approximately 25 seconds, with queue wait under 10 seconds and transcription completing in about 20 seconds on average. These values are in line with our usual operating range.
Jobs submitted during the earlier slowdown have been processed. Service is fully restored.
We apologize for the disruption. If you continue to experience issues, please contact us at support@gladia.io.
Monitoring
We have applied mitigations and pre-recorded transcription performance in Europe is now back to normal levels for new jobs.
Average end-to-end latency for new transcriptions in the EU pipeline is approximately 3 minutes, in line with our usual operating range. Queue wait is under 2 minutes, and transcription itself completes in under 30 seconds on average.
Jobs submitted during the earlier slowdown are still being processed and will complete over the coming hours as the backlog clears. No action is required on your side for those requests.
We continue to monitor the pipeline and will post a final update once all backlog has cleared and performance is confirmed stable.
Investigating
We are still investigating degraded performance on pre-recorded transcription in Europe.
On our side, current average end-to-end latency for jobs in the EU pipeline is about 15 minutes. Most of that time is spent waiting in the processing queue (~10 minutes), with the actual transcription step taking around 2 minutes on average.
We will keep the status page updated as the situation evolves. You can subscribe to alerts there if you have not already.
Investigating
Service is unhealthy