Gladia - API is unreachable via Recall.ai – Incident details

All systems operational

API is unreachable via Recall.ai

Resolved
Operational
Started 20 days agoLasted about 3 hours

Affected

API

Operational from 2:04 PM to 4:38 PM

Updates
  • Resolved
    Resolved

    Starting at around 15:30 UTC+1, all requests coming from Recall.ai began failing. The issue was traced to a specific edge case involving file uploads where a filename is not provided by the client, requiring our system to generate one. While most HTTP clients and browsers include a filename by default—making the issue rare—Recall.ai’s integration did not, triggering the problem.

    This behavior was caused by a recent change deployed at 15:00 UTC+1 to support JSON-formatted logs. As part of that change, the request ID, which is used to generate a filename in the absence of one, was no longer accessible. This resulted in 400 Bad Request errors for affected uploads.

    The issue was identified at 15:30 UTC+1. A fix was reviewed by 16:30 UTC+1 and deployed by 17:00 UTC+1, resolving the problem.

    We are updating our test coverage to include this specific edge case to prevent similar incidents in the future.

  • Monitoring
    Monitoring

    A fix has been deployed. Upload are working again. We are monitoring the situation.

  • Investigating
    Investigating

    Gladia API is currently unavailable via Recall.ai. We reached out to their team to find a solution.