Gladia - Major Outage on Pre-Recorded and Real Time Transcription – Incident details

All systems operational

Major Outage on Pre-Recorded and Real Time Transcription

Resolved
Major outage
Started 2 days agoLasted about 1 hour

Affected

API

Major outage from 8:40 AM to 9:37 AM

Pre-Recorded v2

Major outage from 8:40 AM to 9:37 AM

Real-Time v1

Major outage from 8:40 AM to 9:37 AM

Real-Time v2

Major outage from 8:40 AM to 9:37 AM

App

Major outage from 8:40 AM to 9:37 AM

Addons

Major outage from 8:40 AM to 9:37 AM

Updates
  • Postmortem
    Postmortem

    An incident occurred within our cluster that temporarily prevented the creation of new transcriptions through our APIs from 9:30 AM to 10:30 AM.

    The root cause was identified as a DNS resolution issue affecting one of our load balancers, which is responsible for routing traffic to the transcription services. This issue led to connection errors between the APIs and the services, causing incoming requests to fail.

    To restore service, API traffic was rerouted to another Load Balancer bypassing the affected one.

    Corrective actions are currently in progress to improve DNS resolution reliability and prevent similar incidents in the future.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.